accelerator pump not a pumpin?????????

4doordream
New Member
New Member
Posts: 5
Joined: Mon Apr 12, 2010 7:42 am

accelerator pump not a pumpin?????????

Postby 4doordream » Mon Mar 21, 2011 11:38 am

300 inline 6....with a carter yf 1barrel

when i hit the gas fast it stalls,when i gradually give her its fine.

Just bought truck it is a regular cab(although i do have a crew too!)
drove it home about 20 miles after it had been sitting 3 years(the guy said. i think more)...dump fuel down carb,and some in tank. drove it ;but i had to drive it on full choke to get home. figured a carb cleaning was in order.

did the cleaning with fresh gaskets,put it back together exactly how it come out.....Still does it :cry: ......the carb really wasnt that bad to my surprise;it was rather clean inside and out.... this carb does not have an adjuster screw for accelerator pump inside,and seems to go together only one way.

the carb is reman. from canada on a tag under screw
new gasket kit and acc.pump
new fuel filter,and fuel pump.
there is a new sending unit too as the fuel guage didnt work when i got it.

NOW WHAT????? :?:
buy a new/different carb...money
send it to carburator pro?..money
the carb is rather simple and has got me stumped!!HELP

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.


User avatar
InfoFord
SR Moderator
SR Moderator
Posts: 1421
Joined: Mon Mar 24, 2008 5:03 pm
Location: Kalispell MT
Contact:

Re: accelerator pump not a pumpin?????????

Postby InfoFord » Tue Mar 22, 2011 3:32 pm

when you had it tore apart did you verify all the passages were clear and not plugged

User avatar
dromero
Part Timer
Part Timer
Posts: 30
Joined: Sat Oct 25, 2008 9:41 am
Location: Kennewick, WA

Re: accelerator pump not a pumpin?????????

Postby dromero » Tue Mar 22, 2011 7:28 pm

Check ignition system, make sure timing advances, maybe a defective accelerator pump? also I had a metal float in a rebuilt carb that had a pin hole where it was brazed in the seam, almost burnt the truck up when the float filled with gas and sank to the bottom of the bowl, carb just kept pumping fuel, overflowed the carb. Just something to consider.
'74 F350 Crew
'74 Ford Bronco

Disable adblock

This site is supported by ads and donations.
If you see this text you are blocking our ads.
Please consider a Donation to support the site.



Return to “Engine”




  Who is online

Users browsing this forum: No registered users and 1 guest